Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Групповое изменение реквизитов

Групповое изменение реквизитов
Я
   dvrk
 
21.01.21 - 11:59
Есть какая-нибудь типовая обработка, в которой можно отобрать нужные документы и написать что-то типа СчетФактураВыданная.Номер = ДокументОснование.Номер ?
   DrShad
 
1 - 21.01.21 - 12:01
есть
   ДенисЧ
 
2 - 21.01.21 - 12:01
devtools.ucoz.net

если в адресе не наврал...
   Галахад
 
3 - 21.01.21 - 12:02
А типовое уже не катит?
   DrShad
 
4 - 21.01.21 - 12:02
(2) но это не типовая, а универсальная )))
   ДенисЧ
 
5 - 21.01.21 - 12:04
(4) типа универсальная ))
   DrShad
 
6 - 21.01.21 - 12:05
(5) что значит типа?
еще не встречал конфы на которой поделки ТормозаИТ не работают
   ДенисЧ
 
7 - 21.01.21 - 12:08
(6) Типовая универсальная.
А ты запусти её на ТиС8 )))
   dvrk
 
8 - 21.01.21 - 12:08
А где там что искать... и это платные, да ?
   DrShad
 
9 - 21.01.21 - 12:09
(7) wtf ТиС8?
   ДенисЧ
 
10 - 21.01.21 - 12:09
(8) Нет. Там всё бесплатно 
И даже кнпочки доната не видел )))
   ДенисЧ
 
11 - 21.01.21 - 12:09
(9) Торговля и Склад. 8я.
   dvrk
 
12 - 21.01.21 - 12:11
(10) Мне бы обработку просто скачать, а не расширение, в типовой "Групповое изменение реквизитов" нет в доступных полях ДокументОснование.Номер :(
   dvrk
 
13 - 21.01.21 - 13:31
я не понимаю почему у меня не получается, запросом получаю документы в которых нужно сделать док.номер = докоснование.номер создаю кнопку
наклиенте
насерверебезконтекста пишу запрос + обход но отладкой туда попасть не могу, после НаКлиенте просто в предприятие кидает отладка завершается
это значит отладка на сервере не запущена или что ещё ?
   ДенисЧ
 
14 - 21.01.21 - 13:32
(13) да
   dvrk
 
15 - 21.01.21 - 13:33
(14) а без рестарта службы никак не запустить? в реестре прописал -дебаг
   ДенисЧ
 
16 - 21.01.21 - 13:34
(15) Нет.
   dvrk
 
17 - 21.01.21 - 13:54
(16) всё спасибо большое с отладкой проще стало))))
   dvrk
 
18 - 21.01.21 - 14:14
Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    СчетФактураВыданный.Ссылка КАК Ссылка,
                   |    СчетФактураВыданный.ДокументОснование.Номер КАК ДокументОснованиеНомер,
                   |    СчетФактураВыданный.Номер КАК Номер
                   |ИЗ
                   |    Документ.СчетФактураВыданный КАК СчетФактураВыданный
                   |ГДЕ
                   |    СчетФактураВыданный.Дата МЕЖДУ &Дата И &Дата1
                   |    И СчетФактураВыданный.ПометкаУдаления = ЛОЖЬ
                   |    И СчетФактураВыданный.Проведен";
    Запрос.УстановитьПараметр("Дата", '20201001');
    Запрос.УстановитьПараметр("Дата1",'20201231');
    Результат = Запрос.Выполнить().Выгрузить();
    Для каждого А из Результат Цикл
        А.Номер = А.ДокументОснованиеНомер;
        А.Ссылка.Записать();
        
        КонецЦикла;


сильно не бейте, учусь, как записывать?
метод объекта не обнаружен (записать)
   ДенисЧ
 
19 - 21.01.21 - 14:15
У ссылки нет метода Записать()
Не тебе ли я вчера писал про это?
   dvrk
 
20 - 21.01.21 - 14:16
(19) ну я это уже понял, поэтому спрашиваю как записать
не мне или нет)
   Aleksey
 
21 - 21.01.21 - 14:24
(12) Это табличная часть
   dvrk
 
22 - 21.01.21 - 14:25
(21) с чего номер это табличная часть?
ну и вопрос уже другой
Как записать документ по ссылки
   oslokot
 
23 - 21.01.21 - 14:25
(20) нужно получить объект по ссылке, а затем записать
   dvrk
 
24 - 21.01.21 - 14:28
(23) в цикле получать ?
   dvrk
 
25 - 21.01.21 - 14:30
Результат = Запрос.Выполнить().Выгрузить();
    Для каждого А из Результат Цикл
        А.Номер = А.ДокументОснованиеНомер;
        ОбДокумент=А.Ссылка.ПолучитьОбъект();
        ОбДокумент.Записать();
        
        КонецЦикла;
   Aleksey
 
26 - 21.01.21 - 14:30
(22) С того докОснование храниться в ТЧ, а не в шапки. Иначе как по твоему реализовано 1 фактура на несколько документов
   dvrk
 
27 - 21.01.21 - 14:31
(26) я неправильно понял, сори
   dvrk
 
28 - 21.01.21 - 14:36
(25) почему не записывает ?
   oslokot
 
29 - 21.01.21 - 14:42
скорей всего в методе записать не хватает параметров
   dvrk
 
30 - 21.01.21 - 14:43
(29)  там же нет обзятельных
 
 Рекламное место пустует
   dvrk
 
31 - 21.01.21 - 14:48
Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    СчетФактураВыданный.Ссылка КАК Ссылка,
                   |    СчетФактураВыданный.ДокументОснование.Номер КАК ДокументОснованиеНомер,
                   |    СчетФактураВыданный.Номер КАК Номер
                   |ИЗ
                   |    Документ.СчетФактураВыданный КАК СчетФактураВыданный
                   |ГДЕ
                   |    СчетФактураВыданный.Дата МЕЖДУ &Дата И &Дата1
                   |    И СчетФактураВыданный.ПометкаУдаления = ЛОЖЬ
                   |    И СчетФактураВыданный.Проведен";
    Запрос.УстановитьПараметр("Дата", '20201001');
    Запрос.УстановитьПараметр("Дата1",'20201231');
    Результат = Запрос.Выполнить().Выгрузить();
    Для каждого А из Результат Цикл
           ОбДокумент=А.Ссылка.ПолучитьОбъект();  
        
        А.Номер = А.ДокументОснованиеНомер;
        
        ОбДокумент.Записать(РежимЗаписиДокумента.Запись);
        
    КонецЦикла;

так тож не
   dvrk
 
32 - 21.01.21 - 14:51
Я что-то не так делаю ?
   dvrk
 
33 - 21.01.21 - 15:01
Взял из примеров, там так же делается и всё ок
   dvrk
 
34 - 21.01.21 - 15:04
МОжет мне проще как то из номеров типа 0P000900 делать " 0P900" ?
   Ёпрст
 
35 - 21.01.21 - 15:07
(31)

// А.Номер = А.ДокументОснованиеНомер;
ОбДокумент.Номер = .....
   dvrk
 
36 - 21.01.21 - 15:12
(35) СПАСИБО БОЛЬШОЕ
   TormozIT
 
37 - 21.01.21 - 15:53
(2) Наврал таки. Уже начал забывать )
http://devtool1c.ucoz.ru
   PaulBC
 
38 - 22.01.21 - 04:49
В типовой групповой обработке есть выполнение произвольного алгоритма.
   ДенисЧ
 
39 - 22.01.21 - 05:42
(37) А я никогда и не помнил... гугель у нас на что?
   dvrk
 
40 - 22.01.21 - 06:31
(38) у меня произвольный алгоритм не сработал, примера не нашел


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.